Show Your Support Become A Premier Member


Activity Stream: Show All | New Threads | New Posts | New Pictures | Popular Threads | Lonely Threads | Only Vendor Threads | New Picture Comments | New Profile Comments |
Go Back   G35Driver > General Discussion > G35 Coupe V35 2003 - 07
Sign in using an external account
Register Forgot Password?
Search

Welcome to G35Driver.com!
Welcome to G35Driver.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join G35Driver.com community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 07-24-2012, 01:13 AM
Registered User
Points: 3,278, Level: 35
Points: 3,278, Level: 35 Points: 3,278, Level: 35 Points: 3,278, Level: 35
Level up: 52%, 72 Points needed
Level up: 52% Level up: 52% Level up: 52%
Activity: 7.0%
Activity: 7.0% Activity: 7.0% Activity: 7.0%
Garage is empty, add now
 
Join Date: May 2008
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Cleaned MAF Sensor

Hello everyone,

I recently cleaned my MAF sensor on my 06 G35 sedan with the CRC cleaner. Now I noticed when I am braking and coming to a complete stop I have a slight bump where the engine revs a bit before coming to a complete stop. Anyone know what this is or what I need to do? My check engine light also came on after I cleaned the MAF sensor so I am not sure if that has anything to do with the bump. Any help would be greatly appreciated!

What should I do?
Reply With Quote
  #2  
Old 07-24-2012, 01:27 AM
Registered User
Points: 10,658, Level: 68
Points: 10,658, Level: 68 Points: 10,658, Level: 68 Points: 10,658, Level: 68
Level up: 52%, 192 Points needed
Level up: 52% Level up: 52% Level up: 52%
Activity: 4.8%
Activity: 4.8% Activity: 4.8% Activity: 4.8%
2003 Honda XR250R
My Garage
 
Join Date: Jul 2004
Location: Southeastern Mass.
Posts: 2,681
Thanks: 1
Thanked 89 Times in 73 Posts
iTrader: (1)
Send a message via AIM to partyman66
Pull the Check Engine Light code.... go from there.
__________________
2004 Infiniti G35 Coupe 6MT Diamond Graphite, Navigation, Aero, Premium, Brembos w/Project Mu B-Force Pads, Splash Guards, Aluminum Pedals, Z-Tube and K&N Air Filter, 3/8" Motordyne Spacer 2001 Toyota Tacoma Stepside SR5 5-Speed 4X4 Bridgestone Dueler AT Revo 275/70/16's, Sliders, Tonneau, Bedliner
Reply With Quote
  #3  
Old 07-24-2012, 12:28 PM
Registered User
Points: 3,278, Level: 35
Points: 3,278, Level: 35 Points: 3,278, Level: 35 Points: 3,278, Level: 35
Level up: 52%, 72 Points needed
Level up: 52% Level up: 52% Level up: 52%
Activity: 7.0%
Activity: 7.0% Activity: 7.0% Activity: 7.0%
Garage is empty, add now
 
Join Date: May 2008
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Went to autozone and got the following codes

P0171
PO174
Reply With Quote
  #4  
Old 07-24-2012, 12:29 PM
Registered User
Points: 3,278, Level: 35
Points: 3,278, Level: 35 Points: 3,278, Level: 35 Points: 3,278, Level: 35
Level up: 52%, 72 Points needed
Level up: 52% Level up: 52% Level up: 52%
Activity: 7.0%
Activity: 7.0% Activity: 7.0% Activity: 7.0%
Garage is empty, add now
 
Join Date: May 2008
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Im wondering if the slight bump is due to a vacuum leak
Reply With Quote
  #5  
Old 07-24-2012, 01:41 PM
Registered User
Points: 10,658, Level: 68
Points: 10,658, Level: 68 Points: 10,658, Level: 68 Points: 10,658, Level: 68
Level up: 52%, 192 Points needed
Level up: 52% Level up: 52% Level up: 52%
Activity: 4.8%
Activity: 4.8% Activity: 4.8% Activity: 4.8%
2003 Honda XR250R
My Garage
 
Join Date: Jul 2004
Location: Southeastern Mass.
Posts: 2,681
Thanks: 1
Thanked 89 Times in 73 Posts
iTrader: (1)
Send a message via AIM to partyman66
In the process of cleaning your Mass Airflow Sensor, did you remove any part of the intake piping? Maybe you didn't reconnect everything securely and there's an air leak between one of the connections which is letting un-metered air into the system.

Was your Mass Airflow sensor visibly dirty? If so, it's possible that you sprayed the cleaner all over it, but not enough to completely wisp away the dirt, and the dirt may have dried back on the sensor. I like to saturate my sensors pretty well in the stuff and then kinda shake them by hand so that any of the extra liquid flings off of the sensor rather than all of it drying right in place.
__________________
2004 Infiniti G35 Coupe 6MT Diamond Graphite, Navigation, Aero, Premium, Brembos w/Project Mu B-Force Pads, Splash Guards, Aluminum Pedals, Z-Tube and K&N Air Filter, 3/8" Motordyne Spacer 2001 Toyota Tacoma Stepside SR5 5-Speed 4X4 Bridgestone Dueler AT Revo 275/70/16's, Sliders, Tonneau, Bedliner
Reply With Quote
  #6  
Old 07-24-2012, 02:07 PM
Silencer_0's Avatar
Premier Member
Points: 7,839, Level: 59
Points: 7,839, Level: 59 Points: 7,839, Level: 59 Points: 7,839, Level: 59
Level up: 45%, 111 Points needed
Level up: 45% Level up: 45% Level up: 45%
Activity: 4.3%
Activity: 4.3% Activity: 4.3% Activity: 4.3%
2007 Infiniti G35
 
Join Date: Dec 2008
Location: Corona, SoCal
Posts: 5,489
Thanks: 244
Thanked 253 Times in 143 Posts
iTrader: (25)
Try cleaning the MAF again and let it dry completely before reinstalling. Secure all intake clamps.
__________________
'07 "IS-F Blue" Coupe | MotorDyne | Function & Form | SxExCx | Osiris | WORK | Alliance | 3.7 FD | TransGo | Vortech | ARC

TeamRareJDM
Reply With Quote
  #7  
Old 07-24-2012, 02:13 PM
Registered User
Points: 3,278, Level: 35
Points: 3,278, Level: 35 Points: 3,278, Level: 35 Points: 3,278, Level: 35
Level up: 52%, 72 Points needed
Level up: 52% Level up: 52% Level up: 52%
Activity: 7.0%
Activity: 7.0% Activity: 7.0% Activity: 7.0%
Garage is empty, add now
 
Join Date: May 2008
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
I didnt remove any piping while cleaning, just remove the MAF sensor. Yeah Im going to try to clean it again and see what happens. I will keep you guys posted, thanks for the help
Reply With Quote
  #8  
Old 07-24-2012, 03:16 PM
Registered User
Points: 9,943, Level: 66
Points: 9,943, Level: 66 Points: 9,943, Level: 66 Points: 9,943, Level: 66
Level up: 74%, 107 Points needed
Level up: 74% Level up: 74% Level up: 74%
Activity: 8.3%
Activity: 8.3% Activity: 8.3% Activity: 8.3%
Garage is empty, add now
 
Join Date: Jul 2006
Posts: 1,436
Thanks: 15
Thanked 25 Times in 23 Posts
iTrader: (2)
clean again, make sure it's DRYYYYY.. let it dry for an hour.. i know it's much longer than necessary.. haha

Also.. reset code.. and that rpm bump.. i think it's pretty normal for automatic cars.. all our cars do it.
__________________
2003.5 G35 Sedan, Stock.
Reply With Quote
  #9  
Old 07-24-2012, 03:53 PM
Registered User
Points: 10,505, Level: 68
Points: 10,505, Level: 68 Points: 10,505, Level: 68 Points: 10,505, Level: 68
Level up: 14%, 345 Points needed
Level up: 14% Level up: 14% Level up: 14%
Activity: 45.8%
Activity: 45.8% Activity: 45.8% Activity: 45.8%
Garage is empty, add now
 
Join Date: Apr 2009
Posts: 6,236
Thanks: 72
Thanked 297 Times in 265 Posts
iTrader: (5)
crc maf cleaner dries real quick. i doubt it has anything to do with not giving it enough drying time. one thing to make sure is not to spray it too closely to the sensor as that could damage it. the air pressure is pretty strong from the can
__________________
G35 Coupe Noob here
Reply With Quote
  #10  
Old 07-24-2012, 07:41 PM
Registered User
Points: 3,278, Level: 35
Points: 3,278, Level: 35 Points: 3,278, Level: 35 Points: 3,278, Level: 35
Level up: 52%, 72 Points needed
Level up: 52% Level up: 52% Level up: 52%
Activity: 7.0%
Activity: 7.0% Activity: 7.0% Activity: 7.0%
Garage is empty, add now
 
Join Date: May 2008
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Update: Re-cleaned the MAF and let it dry for 2 hours just to be safe

Running a lot smoother but still have that slight bump before coming to a complete stop. I may take it to my mechanic to have him take a look. I did speak with him and without looking at the car he said it most likely is a faulty MAF sensor. Is there anyway to see if the MAF sensor is working fine?

He quoted me about $200 for the part and wouldnt charge me for the labor since its an easy install. Hes a very honest guy so I trust him. Im also going to have him do a smoke test to make sure its not a vacuum leak.
Reply With Quote
  #11  
Old 07-25-2012, 01:44 AM
Registered User
Points: 9,943, Level: 66
Points: 9,943, Level: 66 Points: 9,943, Level: 66 Points: 9,943, Level: 66
Level up: 74%, 107 Points needed
Level up: 74% Level up: 74% Level up: 74%
Activity: 8.3%
Activity: 8.3% Activity: 8.3% Activity: 8.3%
Garage is empty, add now
 
Join Date: Jul 2006
Posts: 1,436
Thanks: 15
Thanked 25 Times in 23 Posts
iTrader: (2)
Quote:
Originally Posted by fsiddiq3 View Post
Update: Re-cleaned the MAF and let it dry for 2 hours just to be safe

Running a lot smoother but still have that slight bump before coming to a complete stop. I may take it to my mechanic to have him take a look. I did speak with him and without looking at the car he said it most likely is a faulty MAF sensor. Is there anyway to see if the MAF sensor is working fine?

He quoted me about $200 for the part and wouldnt charge me for the labor since its an easy install. Hes a very honest guy so I trust him. Im also going to have him do a smoke test to make sure its not a vacuum leak.
is your car automatic?

i would think if the MAF has issues, the rpm bump will happen at idle also..
post a video.
__________________
2003.5 G35 Sedan, Stock.
Reply With Quote
  #12  
Old 07-25-2012, 12:48 PM
Registered User
Points: 3,278, Level: 35
Points: 3,278, Level: 35 Points: 3,278, Level: 35 Points: 3,278, Level: 35
Level up: 52%, 72 Points needed
Level up: 52% Level up: 52% Level up: 52%
Activity: 7.0%
Activity: 7.0% Activity: 7.0% Activity: 7.0%
Garage is empty, add now
 
Join Date: May 2008
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (0)
Yeah its automatic, I dont get the rpb bump at idle, only when coming to a stop.

Will post video soon
Reply With Quote
  #13  
Old 07-25-2012, 01:06 PM
Registered User
Points: 4,730, Level: 43
Points: 4,730, Level: 43 Points: 4,730, Level: 43 Points: 4,730, Level: 43
Level up: 90%, 20 Points needed
Level up: 90% Level up: 90% Level up: 90%
Activity: 2.5%
Activity: 2.5% Activity: 2.5% Activity: 2.5%
Garage is empty, add now
 
Join Date: Dec 2007
Location: Houston Texas
Posts: 149
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader: (0)
Sounds like first gear?
__________________
2004 Black on Black G35 Coupe **Stock** for now..
Reply With Quote
  #14  
Old 07-27-2012, 01:03 PM
Registered User
Points: 9,943, Level: 66
Points: 9,943, Level: 66 Points: 9,943, Level: 66 Points: 9,943, Level: 66
Level up: 74%, 107 Points needed
Level up: 74% Level up: 74% Level up: 74%
Activity: 8.3%
Activity: 8.3% Activity: 8.3% Activity: 8.3%
Garage is empty, add now
 
Join Date: Jul 2006
Posts: 1,436
Thanks: 15
Thanked 25 Times in 23 Posts
iTrader: (2)
Quote:
Originally Posted by fsiddiq3 View Post
Yeah its automatic, I dont get the rpb bump at idle, only when coming to a stop.

Will post video soon
that's normal
__________________
2003.5 G35 Sedan, Stock.
Reply With Quote
  #15  
Old 07-27-2012, 01:28 PM
Registered User
Points: 3,614, Level: 37
Points: 3,614, Level: 37 Points: 3,614, Level: 37 Points: 3,614, Level: 37
Level up: 76%, 36 Points needed
Level up: 76% Level up: 76% Level up: 76%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Garage is empty, add now
 
Join Date: Jun 2009
Posts: 82
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader: (0)
I have that too...its annoying. I thought its on purpose to match the revs of each downshift.
Reply With Quote
Old 07-27-2012, 01:28 PM
 
 
 
submit to reddit
Reply

Tags
173, air, check, cleaning, codes, diy, driver, engine, flow, g35, light, maf, mass, my350z, sensor


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -4. The time now is 09:59 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2
Copyright 2002 - 2008, G35DRIVER.COM All Rights Reserved.
Advertising - Terms of Service - Privacy Statement - JOBS


G35Driver.com | My350Z.com | MyG37.com | ZDriver.com |

Everyone's Contact Details