Hey guys I'm new here and I'm having some with my 03 g35 automatic - G35Driver
Show Your Support Become A Premier Member



Hey guys I'm new here and I'm having some with my 03 g35 automatic

Reply
 
 
 
Thread Tools Search this Thread Rate Thread
  #1  
Old 02-07-2017, 10:22 PM
Registered User
Thread Starter
 
Join Date: Feb 2017
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Hey guys I'm new here and I'm having some with my 03 g35 automatic

Hey guys,

I'm new to the g35 scene, I got my 03 g35 automatic sedan couple months ago and I haven't had any issues until last couple days.

When i I press on the gas the reva go up and the car will go no more than 10-15 and 20 mph.
I'd really need some help, if anyone has any suggestions or any fixes please let me know.
Thanks!
Reply With Quote
  #2  
Old 02-07-2017, 10:49 PM
Urbanengineer's Avatar
Registered User
iTrader: (2)
 
Join Date: Jun 2013
Location: Pig Town, OHIO
Posts: 6,995
Thanked 540 Times in 508 Posts
Get the car checked for codes as what you are experiencing is called limp mode.
Reply With Quote
  #3  
Old 02-07-2017, 11:26 PM
TIAN's Avatar
Hold The Line
iTrader: (20)
 
Join Date: Oct 2006
Location: SFL
Posts: 17,775
Thanked 620 Times in 404 Posts
What he said^
Reply With Quote
  #4  
Old 02-08-2017, 01:10 AM
Registered User
Thread Starter
 
Join Date: Feb 2017
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Yea im taking it to the mechanics tomorrow hopefully nothing serious,thanks!

Quote:
Originally Posted by Urbanengineer View Post
Get the car checked for codes as what you are experiencing is called limp mode.
Reply With Quote
  #5  
Old 02-08-2017, 06:37 PM
Registered User
Thread Starter
 
Join Date: Feb 2017
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
code p0720 &p1572

Okay so the mechanic didn't have time for me and I ended up going to autozone see if they could get the code reader on and it gave me a code p1572 for vehicle speed sensor error and an p0720 for vehicle speed sensor revolution sensor circuit fault

now all this looks like Chinese to me can I get some suggestions other than to it to a mechanic, I'm still trying to get a hold of him
Reply With Quote
  #6  
Old 02-08-2017, 08:44 PM
Urbanengineer's Avatar
Registered User
iTrader: (2)
 
Join Date: Jun 2013
Location: Pig Town, OHIO
Posts: 6,995
Thanked 540 Times in 508 Posts
Have you done any brake or suspension work recently?
Reply With Quote
  #7  
Old 02-09-2017, 06:29 AM
Blue Dream's Avatar
I drove ttrank's car solo
iTrader: (50)
 
Join Date: Mar 2009
Location: By the sea, Tx
Posts: 15,561
Thanked 1,123 Times in 897 Posts
I'm having some too lolol...........
Reply With Quote
  #8  
Old 02-09-2017, 08:36 AM
Registered User
Thread Starter
 
Join Date: Feb 2017
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
no haven't done anything yet

Quote:
Originally Posted by Urbanengineer View Post
Have you done any brake or suspension work recently?
Reply With Quote
  #9  
Old 02-10-2017, 12:11 AM
Registered User
 
Join Date: Sep 2009
Posts: 27
Thanks: 0
Thanked 1 Time in 1 Post
I would just replace the speed sensor so you don't damage the transmission
Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:08 AM.


Copyright 2002 - 2008, G35DRIVER.COM All Rights Reserved.