My g35 wonít go over 4K rpm After new muffler installation, what is the issue? - Page 4 - G35Driver - Infiniti G35 & G37 Forum Discussion

Go Back  G35Driver - Infiniti G35 & G37 Forum Discussion > General Discussion > G35 Coupe V35 2003 - 07
Reload this Page >

My g35 wonít go over 4K rpm After new muffler installation, what is the issue?

G35 Coupe V35 2003 - 07 Discussion about the 1st Generation V35 G35 Coupe

My g35 wonít go over 4K rpm After new muffler installation, what is the issue?

Reply

 
 
 
  #46  
Old 05-16-2018, 12:21 PM
Registered User
Thread Starter
Join Date: Feb 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts

I will be taking it to a mechanic next week. So I managed to let it idle but itís idling at 2k rpm. I noticed my vdc light is on and my slip light as well, note Iím in Neutral and just turned it on. I tried to do the ecu rEset maybe my timing is bad but I canít seem to get my cel to blink.
 

Last edited by Roy760; 05-16-2018 at 12:29 PM.
Reply With Quote
  #47  
Old 05-16-2018, 12:24 PM
Registered User
Thread Starter
Join Date: Feb 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Also as I was letting it idle just now, it almost stalled by itself and then jumped back up and saved itself if that makes sense. The rpms dropped below 1k then back to 2k, three times. We replaced the accelerator pedal sensor a while back so I also donít know if this is why the gas pedal isnít responding. My brother bought it on eBay so my guess is itís a piece of **** part.
 

Last edited by Roy760; 05-16-2018 at 12:31 PM.
Reply With Quote
  #48  
Old 05-16-2018, 03:11 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 4,599
Thanked 461 Times in 440 Posts
Yep I was just going to say to check the APP switch since you can't get the ECU to reset with the pedal dance, if it does esnt see the switch move fully open/closed then it won't work. You can use an obd2 reader to see what % throttle the ECU is reading from the APP switch.
 
Reply With Quote
  #49  
Old 05-16-2018, 09:25 PM
Registered User
Thread Starter
Join Date: Feb 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
I went ahead and swapped back my old app sensor and installed new camshaft position sensors and it now runs! Bad news is now my vdc and slip light are still on and I canít go over 20mph safely. I did the accelerator ecu rEset and it revvved good for 10 seconds then when I went to drive it and got in gear the slip light and vdc light came on and in neutral it wonít rev, I floor it and it thinks Iím giving like 1/4 throttle so it does go up slow. So looks like as soon as I solve this problem with the vdc and slip light Iíll be back in business, any ideas?
 
Reply With Quote
  #50  
Old 05-16-2018, 09:29 PM
Registered User
Thread Starter
Join Date: Feb 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Here is a clip in its current state, drivable but poor throttle response and new vdc and slip light on. I wouldnít want to drive it that far though.
 
Reply With Quote
  #51  
Old 05-16-2018, 09:50 PM
Blue Dream's Avatar
I drove ttrank's car solo
iTrader: (50)
Join Date: Mar 2009
Location: By the sea, Tx
Posts: 17,463
Thanked 1,328 Times in 1,087 Posts
 
Reply With Quote
The Following User Says Thank You to Blue Dream For This Useful Post:
Scorpi0 (05-17-2018)
  #52  
Old 05-23-2018, 03:01 PM
Registered User
Thread Starter
Join Date: Feb 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
P2122
P2128
P2127
P2138

i took the car to Infiniti, apart from rude service they charged 200 for this information and refuse to elaborate on what is the problem. They told me I can leave the car and theyíll find out but I just wanted to get out of that piece of **** place.
 
Reply With Quote
  #53  
Old 05-23-2018, 03:02 PM
Registered User
Thread Starter
Join Date: Feb 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
The throttle
body is new and the pedal sensor from a g35 sedan and I let hem know this
 
Reply With Quote
  #54  
Old 05-23-2018, 03:06 PM
Registered User
Join Date: Dec 2014
Posts: 659
Thanks: 0
Thanked 61 Times in 50 Posts
Originally Posted by Roy760 View Post
P2122
P2128
P2127
P2138

i took the car to Infiniti, apart from rude service they charged 200 for this information and refuse to elaborate on what is the problem. They told me I can leave the car and theyíll find out but I just wanted to get out of that piece of **** place.

You couldn't retrieve this information from autozone for free?
 
Reply With Quote
  #55  
Old 05-23-2018, 03:21 PM
Registered User
Thread Starter
Join Date: Feb 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by eazdaskeez View Post
You couldn't retrieve this information from autozone for free?
hahahhahah everyone told me to go Infiniti now I shouldíve gone to auto zone?
 
Reply With Quote
  #56  
Old 05-23-2018, 03:24 PM
Registered User
Thread Starter
Join Date: Feb 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
 
Reply With Quote
  #57  
Old 05-23-2018, 03:31 PM
Registered User
Join Date: Dec 2014
Posts: 659
Thanks: 0
Thanked 61 Times in 50 Posts
Ahhhhh I see. My apologies I wasn't really reading in depth. You need to call corporate if you spent 200 bucks and got no explanation and just some codes that could have been retrieved for free.
 
Reply With Quote
  #58  
Old 05-23-2018, 03:38 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 4,599
Thanked 461 Times in 440 Posts
We said go to Nissan for a diagnostic, not to just have the codes scanned...
 
Reply With Quote
  #59  
Old 05-23-2018, 03:40 PM
Registered User
Join Date: Dec 2014
Posts: 659
Thanks: 0
Thanked 61 Times in 50 Posts
Can they really charge 200 for a simple code scan?
​​​
 
Reply With Quote
  #60  
Old 05-23-2018, 05:40 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 4,599
Thanked 461 Times in 440 Posts
You have 4 codes saying something is.wrong with the Accelerator Pedal Position switch. Hook up an OBD2 scanner and read real-time info for the APP to see what it's saying. Next take the pedal off, buy a 3x AA battery holder, wire the positive side to one of the two APP switches, use your digital multimeter and read current as you slowly push the pedal fully closed, voltage should scale from about 1 to 5 volts, rinse/repeat with the second half of the switch, should be about the same values.

If the pedal works properly unplug the ECU and measure resistance from the APP harness to the ECU harness to.make sure it's a continuous circuit for EACH wire.

You will find the problem, either the pedal switch is bad or the wire is bad. If both items pass inspection then you might (unlikely) have a bad ECU.

It's a little time consuming but it's not hard, this is what Nissan will do if you pay them to diagnose the problem. My gut feeling is if you already replaced the APP then you probably bent a wire in the harness or somehow damaged the harness, possible a defective APP, possible a broken wire.
 
Reply With Quote

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: My g35 wonít go over 4K rpm After new muffler installation, what is the issue?


Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: