My g35 wonít go over 4K rpm After new muffler installation, what is the issue? - G35Driver - Infiniti G35 & G37 Forum Discussion

Go Back  G35Driver - Infiniti G35 & G37 Forum Discussion > General Discussion > G35 Coupe V35 2003 - 07
Reload this Page >

My g35 wonít go over 4K rpm After new muffler installation, what is the issue?

G35 Coupe V35 2003 - 07 Discussion about the 1st Generation V35 G35 Coupe

My g35 wonít go over 4K rpm After new muffler installation, what is the issue?

Reply

 
 
 
  #1  
Old 05-03-2018, 06:15 PM
Registered User
Thread Starter
Join Date: Mar 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
My g35 wonít go over 4K rpm After new muffler installation, what is the issue?

Okay I was driving and I tried to go over 4K rpm in my 6mt g35 de coupe and it would like sputter. I then drive it back slow to my house wher I proceed to get this clip of me giving it gas, this is in neutral. Can this be my fuel pump? It was running perfectly yesterday, I did get a muffler installed yesterday as well but what would that have to do with this issue? Any help would be appreciated.
 
Reply With Quote
  #2  
Old 05-03-2018, 08:44 PM
Registered User
Join Date: Feb 2018
Location: LA, Cali
Posts: 756
Thanked 61 Times in 58 Posts
What the hell did I just watch?
 
Reply With Quote
  #3  
Old 05-03-2018, 09:58 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 4,812
Thanked 489 Times in 465 Posts
Coupe 6MT Premium RAS
It would be a lot better without all that music so I could hear the engine. Does it sputter or just not rev. Did you check the exhaust kit to make sure none of the packaging was stuffed into the pipe like they sometimes do?
 
Reply With Quote
  #4  
Old 05-03-2018, 11:18 PM
Registered User
Thread Starter
Join Date: Mar 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by [email protected] View Post
It would be a lot better without all that music so I could hear the engine. Does it sputter or just not rev. Did you check the exhaust kit to make sure none of the packaging was stuffed into the pipe like they sometimes do?
well now it wonít start it just cranks as I was about to get a clip with no music. Well I showed me pressing the gas and the rpms wonít move. It moves up maybe 100 rpm then doesnít respond. What the f can I do about this? If there was packing it wouldnít sound good as it did yesterday as Iím sure the engine would overheat. I had the muffler installed by a shop
 

Last edited by Roy760; 05-04-2018 at 12:06 AM.
Reply With Quote
  #5  
Old 05-04-2018, 12:43 AM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 4,812
Thanked 489 Times in 465 Posts
Coupe 6MT Premium RAS
If it cranks but won't catch there's a good chance the crank position sensor died, typically this would also have a service engine light and a DTC attached but not always.

It could also be causing the throttle problem, it's near exhaust components (sort of) so I would get the vehicle up on jack stands and start looking for melted or damaged wire, harnesses, etc.
 
Reply With Quote
  #6  
Old 05-04-2018, 09:26 PM
Registered User
Thread Starter
Join Date: Mar 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by [email protected] View Post
If it cranks but won't catch there's a good chance the crank position sensor died, typically this would also have a service engine light and a DTC attached but not always.

It could also be causing the throttle problem, it's near exhaust components (sort of) so I would get the vehicle up on jack stands and start looking for melted or damaged wire, harnesses, etc.
so as I was looking at it I decided to crank it again while it was jacked up and I saw smoke come form the starter. I bought a new one and a new crank position senor, replaced both, now it cranks as normal but still wonít start. Tried jumping it so itís not the battery either now I bought ignition coils and spark plugs and Iím going to install them monday and hopefully it will start again. Any other ideas what it could be? Is it a possibility this engine is trashed? I donít even know what else it can be if not any of those things. Iíve crossed these things except th spark plugs off my list until Monday, anything else I should add to the list? I miss driving Bertha ):
 
Reply With Quote
  #7  
Old 05-04-2018, 10:25 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 4,812
Thanked 489 Times in 465 Posts
Coupe 6MT Premium RAS
Did you run out of fuel? You can't always rely on the gauge on the dash so I would add 1 gallon of fresh fuel just to verify the tank isn't on empty. Next up, what is your security indicator doing when you put the key in the ignition and crank? Unfortunately you can't check fuel PRESSURE without buying and installing a sandwich adapter for the fuel damper, Z1 motorsports sells one for cheap though it's like $25 and you also need to buy a schrader valve or fuel pressure gauge for it.
 
Reply With Quote
  #8  
Old 05-04-2018, 11:19 PM
Registered User
Thread Starter
Join Date: Mar 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by [email protected] View Post
Did you run out of fuel? You can't always rely on the gauge on the dash so I would add 1 gallon of fresh fuel just to verify the tank isn't on empty. Next up, what is your security indicator doing when you put the key in the ignition and crank? Unfortunately you can't check fuel PRESSURE without buying and installing a sandwich adapter for the fuel damper, Z1 motorsports sells one for cheap though it's like $25 and you also need to buy a schrader valve or fuel pressure gauge for it.
wow... so the day before I filled in 20$ at a lonely arco gas station. It makes no sense to me t was running perfectly before. I know I pressed 91 like always or maybe I forgot. Could it cause all of This?
 
Reply With Quote
  #9  
Old 05-05-2018, 01:01 AM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 4,812
Thanked 489 Times in 465 Posts
Coupe 6MT Premium RAS
The octane won't matter but if the tank is on empty it's obviously not going to run ...
 
Reply With Quote
  #10  
Old 05-05-2018, 03:28 AM
Registered User
Thread Starter
Join Date: Mar 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by [email protected] View Post
The octane won't matter but if the tank is on empty it's obviously not going to run ...
i put new gas and drained the old, it had plenty of gas before .It almost started but it died and now wonít turn over again.then I decided to Have it push started it ran for a while then it died now it only cranks again. Any other fuel system issues I can look at?
 
Reply With Quote
  #11  
Old 05-05-2018, 06:00 AM
Registered User
Join Date: Feb 2018
Location: LA, Cali
Posts: 756
Thanked 61 Times in 58 Posts
Your fuel pump might be taking a crap.
 
Reply With Quote
  #12  
Old 05-05-2018, 10:19 AM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 4,812
Thanked 489 Times in 465 Posts
Coupe 6MT Premium RAS
Here's that sandwich adapter I was talking about, I guess the price went up a bit, you can add on a schrader valve or gauge from the options at the bottom.
 
Reply With Quote
  #13  
Old 05-05-2018, 06:34 PM
Registered User
Thread Starter
Join Date: Mar 2018
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by [email protected] View Post
Here's that sandwich adapter I was talking about, I guess the price went up a bit, you can add on a schrader valve or gauge from the options at the bottom.
Thanks but I went ahead and bought the fuel pump anyway and installed it, still no luck. Is it my engine? It turns on now but it stays on for like 7 seconds and then dies again. I am becoming hopeless like what the heíll else could it be?
 
Reply With Quote
  #14  
Old 05-05-2018, 07:16 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 4,812
Thanked 489 Times in 465 Posts
Coupe 6MT Premium RAS
Towing it to Nissan for a diagnostic will probably be cheaper then blindly throwing parts at it without troubleshooting...
 
Reply With Quote
  #15  
Old 05-05-2018, 11:05 PM
Blue Dream's Avatar
I drove ttrank's car solo
iTrader: (50)
Join Date: Mar 2009
Location: By the sea, Tx
Posts: 17,601
Thanked 1,342 Times in 1,098 Posts
G35 sedan w/ too much money in mods
Originally Posted by [email protected] View Post
Here's that sandwich adapter I was talking about, I guess the price went up a bit, you can add on a schrader valve or gauge from the options at the bottom.
I keep looking for the adapter and have no idea what the options at the bottom are, methinks we're missing a link.
 
Reply With Quote

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: My g35 wonít go over 4K rpm After new muffler installation, what is the issue?


Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: