G35 Sedan V35 2003-06 Discussion about the 1st Generation V35 G35 Sedan

Will Not Rev Over 2,500 RPM ?????

  #1  
Old 06-07-2010, 05:56 PM
Registered User
Thread Starter
iTrader: (1)
Join Date: Aug 2006
Posts: 299
Likes: 0
Received 4 Likes on 3 Posts
Will Not Rev Over 2,500 RPM ?????

Today while driving the G decided it didn t want to rev over 2,500 while in drive. I switched to manual mode & same deal in each gear. It goes thru the gears (auto) shifting fine, but will not go over 2500. Once it hits 2500 its like the ECU is pulling timing out & shuts off the throttle, like a fuel cut. I tried to rev in P & N and it does the same thing. It did not throw the CEL?

Any suggestions?
 
  #2  
Old 06-07-2010, 05:59 PM
Registered User
iTrader: (7)
Join Date: Jan 2006
Location: Auburn, WA (Lakeland)
Posts: 6,980
Received 13 Likes on 9 Posts
Reset your ECU. Had that happen to me one time in the G37S. It's the vehicle's limp mode.
 
  #3  
Old 06-07-2010, 06:02 PM
Jeff92se's Avatar
Red Card Crew
iTrader: (24)
Join Date: May 2005
Location: ɐʍ 'ǝlʇʇɐǝs
Posts: 36,601
Received 543 Likes on 458 Posts
Sounds like the MAF is faulty. But it should have thrown a cel.
 
  #4  
Old 06-07-2010, 06:02 PM
Registered User
Thread Starter
iTrader: (1)
Join Date: Aug 2006
Posts: 299
Likes: 0
Received 4 Likes on 3 Posts
that's what i was thinking...While i typed this up a fews ago, i just went in the garage & pulled the negative cable off to let sit for about 10-15mins..Hopefully that is it...
 
  #5  
Old 06-07-2010, 06:27 PM
thescreensavers's Avatar
Mr.202?
iTrader: (10)
Join Date: Apr 2009
Location: Miami,FL
Posts: 9,751
Received 202 Likes on 160 Posts
well it went into limp mode for a reason should plug in a code reader and see what code its reading. Before you reset the ECU
 
  #6  
Old 06-07-2010, 06:52 PM
Registered User
iTrader: (7)
Join Date: Jan 2006
Location: Auburn, WA (Lakeland)
Posts: 6,980
Received 13 Likes on 9 Posts
^^ Not necessarily. My G37S went into Limp Mode for absolutely no reason, I reset it and it was perfectly fine the next 25k miles. ECU's can screw up too, just like any computer.
 
  #7  
Old 06-07-2010, 07:04 PM
thescreensavers's Avatar
Mr.202?
iTrader: (10)
Join Date: Apr 2009
Location: Miami,FL
Posts: 9,751
Received 202 Likes on 160 Posts
true, but its always better to check it imo.
 
  #8  
Old 06-07-2010, 08:12 PM
Registered User
Thread Starter
iTrader: (1)
Join Date: Aug 2006
Posts: 299
Likes: 0
Received 4 Likes on 3 Posts
well i reset it & its still doing the exact same thing as above....still no CEL, ..probably bad MAFS, but i will have to bring it in 2mrw to get checked..
 
  #9  
Old 06-07-2010, 08:20 PM
Registered User
iTrader: (7)
Join Date: Jan 2006
Location: Auburn, WA (Lakeland)
Posts: 6,980
Received 13 Likes on 9 Posts
^^ how did you reset the ECU? unplugging the battery for 15 minutes won't do, I believe its at least 12 hours needed or you have to do the ECU reset procedure in the car.

Here's the thread on how to do that:

https://g35driver.com/forums/engine-...resetting.html
 
  #10  
Old 06-07-2010, 08:37 PM
Registered User
Thread Starter
iTrader: (1)
Join Date: Aug 2006
Posts: 299
Likes: 0
Received 4 Likes on 3 Posts
hmmmm....i guess i m going to "foot pump" now....or the 12 hr is next....
 
  #11  
Old 06-07-2010, 08:55 PM
Registered User
Thread Starter
iTrader: (1)
Join Date: Aug 2006
Posts: 299
Likes: 0
Received 4 Likes on 3 Posts
Tried the easy way reset & cant get the cel light to flash...i tried timing it even with a digital stop watch to make sure of the seconds.. i just disconnected it & will wait the 12 hours..benefits of working from home & not having to go to a job at 8am
 

Last edited by 03GT35R; 06-07-2010 at 09:21 PM.
  #12  
Old 06-08-2010, 03:54 PM
Registered User
Thread Starter
iTrader: (1)
Join Date: Aug 2006
Posts: 299
Likes: 0
Received 4 Likes on 3 Posts
The 12 hour reset worked...
 
  #13  
Old 06-08-2010, 04:39 PM
Registered User
iTrader: (9)
Join Date: Aug 2003
Location: Kansas City
Posts: 6,573
Likes: 0
Received 65 Likes on 44 Posts
You're MAF is shot. Replace it.
 
  #14  
Old 06-08-2010, 05:52 PM
Registered User
iTrader: (2)
Join Date: Jun 2010
Location: nenenwk
Posts: 710
Received 28 Likes on 24 Posts
I think you are in limp mode
 
  #15  
Old 06-10-2010, 10:34 AM
Registered User
Thread Starter
iTrader: (1)
Join Date: Aug 2006
Posts: 299
Likes: 0
Received 4 Likes on 3 Posts
The Battery reset removed from limp mode, has'nt acted up since...
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Will Not Rev Over 2,500 RPM ?????


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: