Fuel gauge problem. Detailed. - Page 3 - G35Driver - Infiniti G35 & G37 Forum Discussion

G35 Sedan V35 2003-06 Discussion about the 1st Generation V35 G35 Sedan

Fuel gauge problem. Detailed.

  #31  
Old 06-28-2014, 06:27 PM
Registered User
Join Date: Apr 2005
Posts: 382
Thanked 50 Times in 43 Posts
OK, here's something (like you need more advice from me ) It seems there is a "test mode" for the combination meter (cluster). I've copied the instructions below but all your service manuals are here (thanks to NICO club again):
http://www.nicoclub.com/FSM/G35/Sedan/2005_G35_Sedan/
and this is from the file "di.pdf ", Driver Information System.
 
Attached Thumbnails Fuel gauge problem.  Detailed.-meters.jpg  
  #32  
Old 06-29-2014, 03:18 PM
Registered User
Thread Starter
iTrader: (48)
Join Date: Feb 2008
Location: Chicago
Posts: 2,293
Thanked 50 Times in 44 Posts
Name:  IMG_20140628_184216_zpsoc6a67bq.jpg
Views: 14352
Size:  46.0 KB

Did the testing with the gauge, the FSM states it should look exactly like the picture.

Picture shows gas at half. This obviously isn't half, close but not half.
 
  #33  
Old 06-30-2014, 03:32 PM
Registered User
Join Date: Apr 2013
Location: Utah
Posts: 44
Thanked 6 Times in 5 Posts
Originally Posted by TurTLe* View Post
Son of a.... installed both today and NOTHING has changed.

I'm going to fill up later and hope it just takes a little time but its not looking good...

What else can it be? Think the cluster is bad?
Man!!! That's sucks...sorry to hear it! I'm leaning to the cluster. My only experience with cluster is on a 2004 GMC YukonXL I have. I pulled it out and sent it to be repaired which worked. Wish I knew more... wish my G was working!!! Keep us posted if ya would! Tks!!!
 
  #34  
Old 06-30-2014, 07:43 PM
Registered User
Join Date: Feb 2010
Location: East Coast
Posts: 102
Thanked 7 Times in 7 Posts
Been having the same issue with my fuel level bouncing around and haven't replaced anything yet. I did clean the sensors on both sides and it didn't help. Just went out and performed that self diagnosis that u performed turtle and my fuel level is in the same area where urs is. It would be cool if someone without a fuel gauge issue could perform this test and let us know there results. Im hoping its a sensor issue and not the cluster. Keep us updated with any new info turtle!
 
  #35  
Old 07-17-2014, 05:02 PM
Registered User
Join Date: Jul 2014
Posts: 2
Thanked 0 Times in 0 Posts
I just bought my 03 G35X and found the I have the same problem with the gauge. It will not go pass 3/4 or below 1/4 so I took out the fuel unit on the passenger side and found that the fuel level sensor was not attached to the unit. It was just hanging by the wire. I popped it back in and fit everything up this morning and what do you know...the gauge is reading above 3/4 now since I out $60 worth if gas last night! Don't know if everyone else will have the same luck but it's worth checking out that fuel level sensor first. It's the most logical and easy thing to do.
 
  #36  
Old 07-17-2014, 05:18 PM
Registered User
Join Date: Apr 2013
Location: Utah
Posts: 44
Thanked 6 Times in 5 Posts
Yeah... did that first thing. I believe all who have this issue have pulled both the fuel level sensor and the pump with the sensor. Turtle even replaced both units but no love for him. Tks for feedback, glad yours is working!!
 
The Following User Says Thank You to ranhood For This Useful Post:
Apal35 (07-17-2014)
  #37  
Old 07-18-2014, 01:43 PM
Hotdawwgman's Avatar
Registered User
iTrader: (19)
Join Date: Feb 2008
Location: SoCal/Chicago at Heart
Posts: 7,053
Thanked 123 Times in 108 Posts
Here is an update for me, I took my car into Riverside Infiniti, and that afternoon they told me that the sender units were reading perfect, it was the fuel gauge that is broken... The fix you ask? A brand new gauge cluster... A $1200 part that is back ordered with no ETA when it will be available... Thank god for my extended warranty....
 
  #38  
Old 07-18-2014, 08:01 PM
Registered User
Join Date: Jul 2014
Posts: 2
Thanked 0 Times in 0 Posts
Originally Posted by Hotdawwgman View Post
Here is an update for me, I took my car into Riverside Infiniti, and that afternoon they told me that the sender units were reading perfect, it was the fuel gauge that is broken... The fix you ask? A brand new gauge cluster... A $1200 part that is back ordered with no ETA when it will be available... Thank god for my extended warranty....
Please let us know if the gauge fixes the problem. I thought mine was fixed after my gauge worked after driving about 25 miles. Now I'm back to square one (gauge does not go below 3/4. SMDH...
 
  #39  
Old 02-19-2015, 09:22 PM
Registered User
Join Date: Apr 2005
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Did anyone ever figure out what the problem is here? Is it the cluster?

I had both sending units replaced, and I still have this problem (won't go below half tank).

Thanks!

Josh
 
  #40  
Old 03-01-2015, 09:55 AM
Registered User
Thread Starter
iTrader: (48)
Join Date: Feb 2008
Location: Chicago
Posts: 2,293
Thanked 50 Times in 44 Posts
One person messaged me with the same issues, he got his cluster repaired for like $200. So far so good.

Mines has been working in the cold like 25% of the time compared to 5% in the warmer months.
 
  #41  
Old 05-16-2015, 03:02 AM
Registered User
Join Date: Apr 2013
Location: Utah
Posts: 44
Thanked 6 Times in 5 Posts
TurTLe... you still have same prob? I've just been dealing with it but sure would smile more if fuel gauge worked correctly. Can the instrument cluster be pulled as a whole and repaired? Tks for your feedback!! -r
 
  #42  
Old 05-19-2015, 10:56 AM
Registered User
Join Date: Feb 2015
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
What about if my fuel gauge light is dimmed ???
Originally Posted by ranhood View Post
TurTLe... you still have same prob? I've just been dealing with it but sure would smile more if fuel gauge worked correctly. Can the instrument cluster be pulled as a whole and repaired? Tks for your feedback!! -r
 
  #43  
Old 07-15-2015, 09:45 AM
Patrick Bovee's Avatar
Registered User
iTrader: (1)
Join Date: Feb 2015
Location: Long Island
Posts: 208
Thanked 4 Times in 4 Posts
Nothing more on this? My gas when it hits 1/4th tank it starts rising to like 3/4. After I let it sit and turn on it shows me what im at then rises as I drive!!!
 
  #44  
Old 07-15-2015, 02:35 PM
Registered User
Join Date: Jun 2015
Location: Atlanta/Oxford, GA
Posts: 90
Thanked 11 Times in 11 Posts
I just bought my G three weeks ago now and have the same problem. It rattles me bad that this is happening. Mine goes up and down a little also. Since replacing the sending unit doesn't seem to work I want to see if the cluster replacement is the answer before I buy one.
 
  #45  
Old 07-15-2015, 03:23 PM
Registered User
Join Date: Apr 2013
Location: Utah
Posts: 44
Thanked 6 Times in 5 Posts
So it seems that a repair or replacement of the cluster is the solution. A google search shows a few places repair for $125 - $180. If you tested both sender units - and performed the test SkylineSedan took time to show/link... cluster fix seems to be cost effective solution. I had it done on a Yukon I own about 3 years ago. Complete cure of my gauge probs. Keep us posted on things.
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 1 votes, 5.00 average.

Quick Reply: Fuel gauge problem. Detailed.


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: