General Tech Questions This Forum is Only for Questions and Posts that Do Not fit under the other Tech categories.(No Classified Posts)

VDC and slip light on!

  #1  
Old 12-31-2018, 06:08 PM
Registered User
Thread Starter
Join Date: Dec 2018
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
G37 coupe journey
VDC and slip light on!

08 G37 coupe journey w/ 95k miles automatic transmission. Recently had changed my front brakes replaced (rears need pads soon)

I understand these lights will come on if I'm short on brake fluid or if I need to change my brakes but I doubt this is the issue. Both of these lights came on randomly last night and my car was shifting horribly. Both the upshift and downshift were rough. I was unable to hit the switch to turn on VDC again.

When I started the car this morning, both lights are off and the car runs fine again. Has anyone ever had this issue? I don't believe my brakes would have anything to do with the rough shifting but I'll have the rear brakes replaced until I can find a solution. I'm hoping this was a one time thing that happened randomly and that it won't be a major issue.
 

Last edited by Jeruel Morales; 12-31-2018 at 07:38 PM.
  #2  
Old 12-31-2018, 07:35 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 6,577
Received 756 Likes on 699 Posts
Coupe 6MT Premium RAS
Need more clarification about "all my tranny fluids changed".

Who did the fluid change, if it was anyone other than the Nissan or Infiniti dealership then EXACTLY what fluid did they use? Was it a drain and fill or was it a powerflush?
 
  #3  
Old 12-31-2018, 07:43 PM
Registered User
Thread Starter
Join Date: Dec 2018
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
G37 coupe journey
Originally Posted by [email protected] View Post
Need more clarification about "all my tranny fluids changed".

Who did the fluid change, if it was anyone other than the Nissan or Infiniti dealership then EXACTLY what fluid did they use? Was it a drain and fill or was it a powerflush?
sorry, that was an error... I got my car to the dealer to change the 6 coils and from that time the car started to run slower and I wasnít responding as fast as before... then the problems kept coming. My car now doesnít have warranty so I donít want to take it to the dealer no more cause every time I take it to the dealer, something else happens
 
  #4  
Old 12-31-2018, 07:49 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 6,577
Received 756 Likes on 699 Posts
Coupe 6MT Premium RAS
You had the service work performed at the Nissan or Infiniti dealership correct? And they used 100% OEM coil packs?

What was the original reason for replacing all 6 coil packs?
 
  #5  
Old 12-31-2018, 09:38 PM
Registered User
Thread Starter
Join Date: Dec 2018
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
G37 coupe journey
Well I think they use OEM parts because it was at Infiniti dealer... I went to the dealer to change the coils cause one of them was giving me trouble... so they said I had to replace all 6 because of the millage
 
  #6  
Old 12-31-2018, 09:49 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 6,577
Received 756 Likes on 699 Posts
Coupe 6MT Premium RAS
Of course they did...

For the future there is absolutely no reason to change a coil pack unless it malfunctions. It's a component that's good for 300k+ miles or more with no moving pieces but they eventually fail randomly.
 
  #7  
Old 12-31-2018, 09:51 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 6,577
Received 756 Likes on 699 Posts
Coupe 6MT Premium RAS
As for the transmission issue I suspect an electrical malfunction, clean the battery terminals, both ends of the negative cable, the engine to chassis jumper on the timing cover, both of the grounds on top of the timing cover, one of them is the transmission ground and the most common point of 5AT malfunction.
 
  #8  
Old 01-01-2019, 04:08 PM
Registered User
Thread Starter
Join Date: Dec 2018
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
G37 coupe journey
Thank you very much! Let me see if thatís it cause the Transmision issue only happens when those lights are on, otherwise it doesnít happen and it shifts good.
 
  #9  
Old 01-01-2019, 04:11 PM
Registered User
Thread Starter
Join Date: Dec 2018
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
G37 coupe journey

 
  #10  
Old 01-01-2019, 08:01 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 6,577
Received 756 Likes on 699 Posts
Coupe 6MT Premium RAS
Looks like you have something wrong with the front two wheel speed sensors, those are definitely causing slip and VDC lights to come on.

I'd check for physical damage to the wiring, you just had the front brakes done and I'm betting the mechanic that did the work either strained the harness OR just didn't plug everything back in correctly. The chances of them both going out at the same time are incredibly slim, start by inspecting the front right wheel speed sensor since it's throwing the most codes.

FIRST HOWEVER I'd have that battery tested to see if that abnormal battery voltage code is true or not, also clean up the battery cables really good because you can have a cascade of DTC's from a low battery.

The EVAP leak might be causing all those codes related to the catalytic converter, O2 sensors, I would definitely fix the EVAP system first before troubleshooting too deeply into the rest of those problems.

MM switch is probably fried, common problem and won't affect normal driveability but you won't be able to do manual gear selection on the transmission.

Knock sensor is probably the sub harness, common failure point, usually requires removal of the upper/lower plenum and the lower collecter intake. Some folks have managed to replace it with a coathook and a lot of patience... ymmv but it's worth looking up a youtube video so you can see what that entails.
 
  #11  
Old 01-01-2019, 08:33 PM
Registered User
Thread Starter
Join Date: Dec 2018
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
G37 coupe journey
Thanks bro! Btw I also changed my MAF sensor cause the car was shutting off and losing strength but it didnít do anything.... the car still runs slow and drives rough... and shift like crazy, down shift and up shifts like crazy... but is only one those lights come on (intermittent cause I doesnít do it everytime, just sometimes)
 
  #12  
Old 01-03-2019, 07:36 PM
Registered User
Join Date: May 2015
Posts: 2
Received 1 Like on 1 Post
This morning my VDC off, ABS and SLIP lights came on when I started the car. In the past, if I shut the car off and restarted they would go off. Today they stayed on. I was at work for 8 hours and when I left and started the car they came on and stayed on all the way home. Car seems to be running fine, no performance issues. Any idea what they might mean?
Thanks!!
 
  #13  
Old 01-06-2019, 11:47 AM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 6,577
Received 756 Likes on 699 Posts
Coupe 6MT Premium RAS
Originally Posted by Tim Flynn View Post
Any idea what they might mean?
Thanks!!
Those lights mean the ECM or TCM has detected something outside the normal operating parameters. If you have the vehicle scanned with an OBD2 scanner you can retrieve the Diagnostic Trouble Codes (DTC) which will tell you the sensors that are detecting problems. From that point you can use the power of the internet to reference possible causes and begin the troubleshooting process.
 
  #14  
Old 02-21-2019, 05:24 AM
Registered User
Join Date: Apr 2017
Posts: 7
Received 0 Likes on 0 Posts
2006 G35 2 door coupe lowered, coil-overs, 1" spacers on wheels, SpecD tuning Cat Back, CAI
VDC, Slip and other lights on

Originally Posted by [email protected] View Post
Those lights mean the ECM or TCM has detected something outside the normal operating parameters. If you have the vehicle scanned with an OBD2 scanner you can retrieve the Diagnostic Trouble Codes (DTC) which will tell you the sensors that are detecting problems. From that point you can use the power of the internet to reference possible causes and begin the troubleshooting process.

VDC, Slip, Brake and Battery lights came on tonight. Recently installed a catback exhaust last week then noticed the VDC and Slip lights came on after I left the shop. Was thinking of also getting an OBDC II scanner soon as well. Any idea how to rectify it? Possibly reset the ECU?
 
  #15  
Old 02-21-2019, 05:42 AM
Registered User
Join Date: Feb 2018
Location: LA, Cali
Posts: 1,252
Received 119 Likes on 112 Posts
Seems like any little crap will set off the VDC and Slip lights on these cars. Easiest way to read and erase codes is with a scanner. Or if u just wanna reset it, u can leave the battery disconnected for a few mins.
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: VDC and slip light on!


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: