Swapped dashes. Now Auto/Climate control doesn't work - G35Driver - Infiniti G35 & G37 Forum Discussion
Show Your Support Become A Premier Member



Swapped dashes. Now Auto/Climate control doesn't work

Closed Thread
 
 
 
Thread Tools Search this Thread Rate Thread
  #1  
Old 08-11-2017, 06:56 PM
Registered User
Thread Starter
 
Join Date: Jun 2013
Location: Tampa, Fl
Posts: 150
Thanked 20 Times in 20 Posts
Swapped dashes. Now Auto/Climate control doesn't work

Hey fellow members, recently I swapped dashes with a recovered dash I have been working on for a while. The whole swap went smoothly with a few f-bombs here and there. If anyone has questions about that, ask away. The only thing that I can't figure out is my auto climate control doesn't work like it used to RIGHT before the swap. Whatever temperature you set it for, the air goes straight to the feet. Blows cold air, just doesn't go to the correct vents. Any ideas what could have happened during the swap to cause this?

Thanks in advance
  #2  
Old 08-11-2017, 07:03 PM
Registered User
Thread Starter
 
Join Date: Jun 2013
Location: Tampa, Fl
Posts: 150
Thanked 20 Times in 20 Posts
Already took the headunit back out and checked all the connections. All seems good. Only thing I can really think of is when I unplugged the a/c display, I tired to turn the air on, which it didn't. I just figured the button communicates with the display and the two won't work without each other. Maybe I screwed up the communication between the two by pressing buttons with the display removed??
  #3  
Old 08-11-2017, 10:02 PM
cleric670@gmail's Avatar
Cleric670
 
Join Date: May 2017
Location: Washington State
Posts: 1,640
Thanked 138 Times in 135 Posts
Are you sure you didn't dislodge or damage the connector/wiring for the mode door motor? It's all part of the communications wiring behind the head unit.

EDIT: Does the display change to show the different modes when you press the button or is it just unresponsive? If the mode button doesn't change the display then I'd suspect something physically wrong with the BUTTON ITSELF.
  #4  
Old 08-11-2017, 10:53 PM
Registered User
Thread Starter
 
Join Date: Jun 2013
Location: Tampa, Fl
Posts: 150
Thanked 20 Times in 20 Posts
The mode button works fine. It's just when you press the auto/econ button the blend door actuator goes to the feet full speed instead of the top vents. A/c/heat/defrost all work. I can switch through each mode and the air goes to the right vents. So I suppose the wiring/connector would be in check.
  #5  
Old 08-11-2017, 11:31 PM
Urbanengineer's Avatar
Registered User
iTrader: (2)
 
Join Date: Jun 2013
Location: Pig Town, OHIO
Posts: 7,944
Thanked 627 Times in 593 Posts
The heat controller plug is behind the stereo, and the ambient air sensor is right by your right knee when sitting in the car.
The Following User Says Thank You to Urbanengineer For This Useful Post:
FreshLikeAG (08-13-2017)
  #6  
Old 08-12-2017, 09:56 AM
Registered User
Thread Starter
 
Join Date: Jun 2013
Location: Tampa, Fl
Posts: 150
Thanked 20 Times in 20 Posts
Looked further into the functions of the sensors and location. Gonna take a crack at it this morning when it stops raining. I feel I either broke something or forgot to reconnect something while putting the dash back together.
I also tried and failed to enter the self diagnostic mode that checks the ambient sensors and actuator motors for the a/c.
Quote:
Shifting from normal control to the self-diagnosis system is accomplished by
starting the engine (turning the ignition switch ON) and pressing OFF switch for at least 5 seconds. The OFF
switch must be pressed within 10 seconds after starting the engine (ignition switch is turned ON). This system
will be canceled by either pressing AUTO.ECON switch or turning the ignition switch OFF. Shifting from one
step is accomplished by means of turning temperature control dial, as required.
I followed directions to the tee. Could it be because I have the cheap a$$ metra double din kit?

Last edited by FreshLikeAG; 08-12-2017 at 11:34 AM.
  #7  
Old 08-12-2017, 01:42 PM
cleric670@gmail's Avatar
Cleric670
 
Join Date: May 2017
Location: Washington State
Posts: 1,640
Thanked 138 Times in 135 Posts
Yes, I too have the cheap *** metra double din kit and cannot enter diagnostic mode. I think the issue is actually communication with the AC/Audio controller, an aftermarket stereo won't allow it to enter diagnostic mode is my guess.

My AC is completely functional however, just unable to enter diagnostic mode.
The Following User Says Thank You to [email protected] For This Useful Post:
FreshLikeAG (08-13-2017)
  #8  
Old 08-12-2017, 02:33 PM
Registered User
Thread Starter
 
Join Date: Jun 2013
Location: Tampa, Fl
Posts: 150
Thanked 20 Times in 20 Posts
Good news! The rain finally held up here and got to look at the car. First thing I checked was the ambient sensor and noticed immediately the wire was tucked away and never got connected. Plugged the wire right in and I have climate control once again. That little vent was filled with dust also, maybe check yours. Once you said where that sensor was I was pretty confident I forgot about that connector. These boards are so helpful, glad I could cross off self diagnostic not working because of aftermarket headunit. I actually ran out of sunlight when swapping dashes and was pretty rushed putting the few final panels back together. Glad it was a 5 minute fix and thanks for pointing me in the right direction. Enjoy the weekend!
  #9  
Old 08-12-2017, 03:25 PM
cleric670@gmail's Avatar
Cleric670
 
Join Date: May 2017
Location: Washington State
Posts: 1,640
Thanked 138 Times in 135 Posts
Awesome, glad everything is working again.
 
 
Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:07 AM.


Copyright ©2002 - 2017, G35DRIVER.COM All Rights Reserved. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: