03 g35 help - G35Driver - Infiniti G35 & G37 Forum Discussion

TSB- Technical Bulletins Technical Service Bulletins- Coupe and Sedan from Infiniti. Updates Approved by Administrators and Moderators.

03 g35 help

  #1  
Old 02-05-2016, 12:35 AM
Registered User
Thread Starter
Join Date: Feb 2016
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy 03 g35 help

Okay so I'm needing some help with my 03 g35 coupe 6 speed. My car is acting up bad so here recently. Okay some times it's hard to start and when it does start it's idles around 600 rpms and has like a hesitation when I give it gas when I'm driving it won't go past 4k. I took the car out today and when I started up a hill the car started losing power and back firing and then completely died. I got it started back but it kept dying unless I was on the throttle. I ran the self diagnostics and it showed now codes at all. I had it hooked up to a OBD-2 scanner and it came back as the knock sensor. It's not smoking or making any noises just running my crap. I'm not sure what else to do I've cleaned the maf checked all sensors and I can't figure it out
 
  #2  
Old 02-05-2016, 01:15 AM
Registered User
iTrader: (9)
Join Date: Feb 2009
Location: 310 Socal
Posts: 1,009
Thanked 43 Times in 39 Posts
i am surprised it is not throwing coeds. but check you spark plugs and your injectors.

usually if it wont let you go past 4K RPM then you are in limp mode and it will throw a code. double check
 
  #3  
Old 02-05-2016, 01:22 AM
Registered User
Thread Starter
Join Date: Feb 2016
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
I will check them tm and yeah I'm surprised it's not throwing codes either.
 
  #4  
Old 02-05-2016, 01:45 AM
Registered User
Join Date: Feb 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
I am having the exact same problem I was overheating I changed thermostat that's ok but still having same issue spark plugs tomorrow when I hooked up scanner said everything ok?
 
  #5  
Old 02-05-2016, 01:49 AM
Registered User
Thread Starter
Join Date: Feb 2016
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by 555555559 View Post
I am having the exact same problem I was overheating I changed thermostat that's ok but still having same issue spark plugs tomorrow when I hooked up scanner said everything ok?
Mines the same way I'm gonna check my spark plugs tm mine could be my fuel pump I'll check that tm as well mine sounds like it running out of fuel up a hill or something don't know exactly how to explain it
 
  #6  
Old 02-06-2016, 06:18 AM
Benny Manjoro's Avatar
Registered User
Join Date: Feb 2015
Location: Victoria Falls
Posts: 2
Thanked 0 Times in 0 Posts
i have the exact same problem annoying missfire with no codes whatsoever,changed injectors,coil packs,and fuel pumps but the problem still persists.its missing only in cylinder 4 and 6.i`m told i have to have the coil pack wires and connections checked.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
edman911
G35 Coupe V35 2003 - 07
3
08-19-2016 05:42 AM
Richie8
G35 Coupe V35 2003 - 07
6
02-09-2016 08:58 PM
MarkeeG35
Engine - Exhaust
0
12-11-2015 02:28 PM
MustangInfiniti
G35 Coupe V35 2003 - 07
10
12-11-2015 09:33 AM
deathdoakill
G35 Coupe V35 2003 - 07
4
11-29-2015 03:20 AM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: 03 g35 help


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: