Engine stalls. Need help! - G35Driver
Show Your Support Become A Premier Member



Engine stalls. Need help!

Reply
 
 
 
Thread Tools Search this Thread Rate Thread
  #1  
Old 12-05-2016, 05:53 AM
Registered User
Thread Starter
 
Join Date: Dec 2016
Posts: 3
Thanked 0 Times in 0 Posts
Engine stalls. Need help!

When I am at a stoplight, or even sometimes making a slow turn, my engine will stall out! The dash lights stay on but I noticed the RPM's drop to zero and I have to turn the car off then on again. It is usually a long start too, almost to the point where it feels like it won't start but it eventually does. The service engine soon light also comes on, but goes away when I turn the car back on.

Thanks
Reply With Quote
  #2  
Old 12-05-2016, 04:50 PM
Registered User
 
Join Date: Dec 2016
Posts: 7
Thanked 1 Time in 1 Post
first thing i would do is pull the code when ur SES light comes on, thats your starting point,
Reply With Quote
The Following User Says Thank You to 1st-gen-G For This Useful Post:
capito_cvn (12-05-2016)
  #3  
Old 12-05-2016, 05:27 PM
Registered User
Thread Starter
 
Join Date: Dec 2016
Posts: 3
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by 1st-gen-G View Post
first thing i would do is pull the code when ur SES light comes on, thats your starting point,
I didn't really think of that considering the light goes away when I turn the car back on, not to mention this has happened twice in traffic with no way of reading the code before the light goes away. However, I remembered that some codes are saved in memory (right?) and I scanned it anyway. P0340 cam shaft position sensor "A" circuit or bank 1. I hear these are a common issue. Now what side is bank 1 standing in front of the car looking at the engine bay?

Thanks again for the quick reply!
Reply With Quote
  #4  
Old 12-05-2016, 05:27 PM
Registered User
Thread Starter
 
Join Date: Dec 2016
Posts: 3
Thanked 0 Times in 0 Posts
Also, do I just replace both sensors? Is it worth it?
Reply With Quote
  #5  
Old 12-06-2016, 12:26 AM
Registered User
 
Join Date: Dec 2016
Posts: 7
Thanked 1 Time in 1 Post
bank 1 is passenger side and i went with oem when mine failed. i changed only the faulty one and its been over 2 years since with other one working properly so i wouldnt throw additional money at it if it aint broke
this site has already covered this issue check out the following thread
https://g35driver.com/forums/engine-...-ses-slip.html
Reply With Quote
  #6  
Old 12-16-2016, 03:07 AM
Blue Dream's Avatar
I drove ttrank's car solo
iTrader: (50)
 
Join Date: Mar 2009
Location: By the sea, Tx
Posts: 15,747
Thanked 1,139 Times in 911 Posts
Check out the thread I started a couple of days ago, 211 views so far and not one comment. This site really is dying a quick death I fear...........

https://g35driver.com/forums/g-spot/...xperiment.html
Reply With Quote
  #7  
Old 12-16-2016, 04:15 AM
ScraggleRock's Avatar
Registered User
iTrader: (4)
 
Join Date: Dec 2013
Posts: 6,356
Thanks: 0
Thanked 660 Times in 560 Posts
Clean your throttle body and MAF.

You have carbon on the butterfly hinges of your tb. C'mon, guys, this is elementary.
Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:05 PM.


Copyright 2002 - 2017, G35DRIVER.COM All Rights Reserved.
 
  • Ask a Question
    Get answers from community experts
What's your question?
Send