Engine, Drivetrain & Forced-Induction Have Technical Questions or Done Modifications to the G35? Find out the answer in here! (View All Posts)

Car will crank but no start :(

  #16  
Old 08-27-2012, 06:21 AM
Registered User
iTrader: (1)
Join Date: May 2008
Location: Greenwood, MS
Posts: 63
Likes: 0
Received 0 Likes on 0 Posts
I'm pretty sure the same thing happened to me a few months ago. I found out that I had to replace two sensors (cam position I think but I forget) and it cost about 120 dollars for parts.
 
  #17  
Old 08-27-2012, 06:37 PM
Xx AzN xX's Avatar
Registered User
Thread Starter
iTrader: (12)
Join Date: Jan 2012
Posts: 253
Received 2 Likes on 2 Posts
Ok found out what the problem is. So i pulled the plugs and i tested it for spark but nothing. No spark from any of the cylinders. All i did was take a jumper cable and clamp one end on thw threads of the plug and the other end to the negative side of the battery. And no spark.

So dose this mean i need a new crank/cam sensor?
 

Last edited by Xx AzN xX; 08-27-2012 at 07:05 PM.
  #18  
Old 08-27-2012, 07:04 PM
UCIMAplaya2's Avatar
Registered User
iTrader: (8)
Join Date: May 2009
Location: Orlando FL
Posts: 603
Received 15 Likes on 13 Posts
probably but if you scan for stored codes you may find a more definitive answer stored in your cars ecu
 
  #19  
Old 08-27-2012, 08:56 PM
Xx AzN xX's Avatar
Registered User
Thread Starter
iTrader: (12)
Join Date: Jan 2012
Posts: 253
Received 2 Likes on 2 Posts
Ok i just ordered a obd 2. It will still scann even if the car dosent start right? Just as long as it can get to the on position? When all the dash lights go on?
 
  #20  
Old 08-27-2012, 09:53 PM
UCIMAplaya2's Avatar
Registered User
iTrader: (8)
Join Date: May 2009
Location: Orlando FL
Posts: 603
Received 15 Likes on 13 Posts
Correct
 
  #21  
Old 08-28-2012, 12:16 PM
Registered User
iTrader: (3)
Join Date: Feb 2012
Posts: 242
Received 26 Likes on 22 Posts
if you get no codes back from the reader u may have a bad ECU or IPDM could be bad as well. Similar thing happened to me last year i had to have infiniti put a new ECU in for me. I was in power train warranty by 3 miles lol. It took quite some time to get the work done. 2 months i think. Good luck.
 
  #22  
Old 08-28-2012, 11:04 PM
Xx AzN xX's Avatar
Registered User
Thread Starter
iTrader: (12)
Join Date: Jan 2012
Posts: 253
Received 2 Likes on 2 Posts
The scanner didnt read any codes.....
 
  #23  
Old 08-28-2012, 11:57 PM
Plur's Avatar
Registered User
iTrader: (17)
Join Date: Nov 2010
Location: San Francisco
Posts: 1,414
Received 102 Likes on 70 Posts
I say it's the ECU. Good luck
 
  #24  
Old 08-29-2012, 12:23 AM
Registered User
iTrader: (3)
Join Date: Feb 2012
Posts: 242
Received 26 Likes on 22 Posts
Are the fans on when u have the car in the on position. If there are ECU for sure
 
  #25  
Old 08-29-2012, 12:29 AM
Xx AzN xX's Avatar
Registered User
Thread Starter
iTrader: (12)
Join Date: Jan 2012
Posts: 253
Received 2 Likes on 2 Posts
No there not. When you guys have the key turned on the on postion is the security light a solid red?
 
  #26  
Old 08-29-2012, 01:09 AM
SUMATIC's Avatar
Registered User
Join Date: Jun 2012
Location: North Shore, Hawaii
Posts: 211
Received 2 Likes on 2 Posts
before you assume its the ECU, i would stop and over look everything again. You should know already that an ECU is very expensive especially from dealer. Did you scan the system properly? history AND active codes? i would suggest try to get a home scanner or a shop to scan it and get some live data on whats going on. and go from there. i know its very unlikely that all coil packs could go bad, but try and find if you know someone with a G and borrow a coil pack and try to test for spark again. and when was the last time youve changed your plugs?
 
  #27  
Old 08-29-2012, 01:14 AM
Registered User
iTrader: (3)
Join Date: Feb 2012
Posts: 242
Received 26 Likes on 22 Posts
If the fans aren't spinning it's most likely a nats problem. Take it to Infiniti or Nissan and they will run a consult. My buddy is a Nissan tech. And he said its probably an key issue either lost the code or a broken key.
 
  #28  
Old 08-29-2012, 02:17 AM
SUMATIC's Avatar
Registered User
Join Date: Jun 2012
Location: North Shore, Hawaii
Posts: 211
Received 2 Likes on 2 Posts
Originally Posted by DrivenG View Post
If the fans aren't spinning it's most likely a nats problem. Take it to Infiniti or Nissan and they will run a consult. My buddy is a Nissan tech. And he said its probably an key issue either lost the code or a broken key.
im sorry but to better my understanding.. a NATS problem, meaning?
not being stupid or anything but just so i understand, as a key issue or lost code, could you explain how it affects the no start?
 
  #29  
Old 08-29-2012, 02:29 AM
SUMATIC's Avatar
Registered User
Join Date: Jun 2012
Location: North Shore, Hawaii
Posts: 211
Received 2 Likes on 2 Posts
never mind. i know what youre talking about. the IVIS right? and yes it makes sense.

Xx AZN xX no problems with the key or anything? did you try to stick a different key in by accident prior to the no start?
 
  #30  
Old 08-29-2012, 03:14 AM
Registered User
iTrader: (3)
Join Date: Feb 2012
Posts: 242
Received 26 Likes on 22 Posts
Well NATS is the key locator that sees the correct key to start the vehicle. If it lost the code or the key is broken the car will crank because the key is cut for the ignition but will not turn over since it doesn't recognize the key. The solid red security light is another indicator of this.
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Car will crank but no start :(


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: