Engine trouble - G35Driver - Infiniti G35 & G37 Forum Discussion

Engine, Drivetrain & Forced-Induction
Have Technical Questions or Done Modifications to the G35? Find out the answer in here! (View All Posts)

Engine trouble

Reply

 
 
 
  #1  
Old 09-26-2015, 12:56 PM
Registered User
Thread Starter
Join Date: Jul 2015
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Engine trouble

2011 G37x w/ 42k miles here.
Was on interstate about 200 miles from home on the last leg of a 1000 mile trip. Car running fine at 80-85 when suddenly the slip light and SES light came on and car began stuttering, losing power. Stop at next exit check brake fluid, gas cap, turn off traction control, nothing out of the ordinary other than a rougher than normal idle.

During the final 200 miles the car would intermittently display the slip light and, at this point, the SES was constant, power was ok so long as I did not get into high RPM's. The following day, no slip light however SES persists. Take car to Auto Zone and scan shows P0102 code.

- Faulty mass air flow sensor
- Intake air leaks
- Dirty mass air flow sensor
- Dirty mass air filter
- Mass air flow sensor harness is open or shorted
- Mass air flow sensor circuit poor electrical connection

Moving along- I clean MAF sensors, verify (I think) no vacuum leaks, filters are new, checked for clogs or debris in intake, etc.

I can unplug one of the MAF's and the car will continue to run, and revs increase a bit. I then plug it back in and unplug the other sensor, the car stalls. I switch the MAF's to opposite sides and repeated the process and the other side stalls the car. By process of elimination, the MAF sensor must be faulty, right?

I buy a new MAF, install and reset ECM. no dice. Still rough idle, no power and now it SES blinks above 3k RPM.. In park I can rev to appx 5k RPM and no lights. However, now when driving the SES no longer stays on constantly it just blinks which, as I understand it, indicates a misfire.

So, my question, could I have created another issue by driving the car 220+ miles home with slip and SES lights on? The replacement MAF seems to have resolved the P0102 code however now I am experiencing blinking SES, terrible idle and misfires around and above 3k RPM.

Thanks!
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Joe Gargano
Engine, Drivetrain & Forced-Induction
1
09-18-2015 11:17 AM
UndyingDest
Drivetrain
1
09-07-2015 12:49 AM
Jnm07
G35 Coupe V35 2003 - 07
10
09-05-2015 01:16 AM
Freeman186
Engine, Drivetrain & Forced-Induction
0
09-04-2015 11:28 PM
magnetism80
G35 Coupe V35 2003 - 07
2
09-02-2015 01:08 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Engine trouble


Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: