G35 Coupe V35 2003 - 07 Discussion about the 1st Generation V35 G35 Coupe

Gauges reading incorrectly

  #1  
Old 05-15-2019, 12:48 PM
Skippedcollege's Avatar
Registered User
Thread Starter
Join Date: Dec 2015
Location: Fort Bragg, North Carolina
Posts: 55
Received 5 Likes on 5 Posts
Gauges reading incorrectly

As always please direct me to a thread covering this if there is one, I couldn't find one.
Anyways, I installed some gauges that I had the color changed on, they are not the ones originally from my car but a donor car. Since I installed them they haven't read accurately. The speedometer reads 10 mph fast (if you are going 45 they read 55), the temp gauge is a touch over the middle even though its at normal temp, the gas gauge when full reads over full and the tachometer reads about 400 rpms high (4000 rpm looks like 4400).
Any ideas on how to reset these or am I just not gonna be able to? I'd like to keep them as I spent nearly $300 on them.
Side note I replaced the climate control readout as well, and I lost my dual zone climate, so if anyone has any thoughts on that it'd be appreciated.

Thanks in advance
 
  #2  
Old 05-15-2019, 12:55 PM
Registered User
iTrader: (1)
Join Date: Aug 2015
Location: Pacific North West
Posts: 472
Received 42 Likes on 41 Posts
Maybe if you'd gone to college you'd know how to fix it!

Sorry, wish I could help but I have no idea - worth pulling the negative battery terminal for an hour or so and see if it resets itself?
 
The following users liked this post:
Skippedcollege (05-15-2019)
  #3  
Old 05-15-2019, 02:45 PM
Registered User
iTrader: (1)
Join Date: Sep 2014
Location: Walpole MA
Posts: 155
Received 8 Likes on 7 Posts
look for the gauge self test instructions. there's a button press sequence that will put the needles at specific positions. if your needles don't go to those positions it probably means they were put on in the incorrect positions when the cluster was reassembled. if you want them to read correctly, you'll probably need to move the needles to point in the right place during the self test.

i think it's push and hold odometer button while turning key to accessory or something like this....
 
The following users liked this post:
Skippedcollege (05-15-2019)
  #4  
Old 05-15-2019, 02:46 PM
Skippedcollege's Avatar
Registered User
Thread Starter
Join Date: Dec 2015
Location: Fort Bragg, North Carolina
Posts: 55
Received 5 Likes on 5 Posts
Awesome thanks, I'll definitely give that a shot
 
  #5  
Old 05-18-2019, 06:39 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 7,018
Received 822 Likes on 756 Posts
Coupe 6MT Premium RAS
I suspect something wrong with one of the two primary instrumentation grounds. There's one directly behind the combination meter, one directly behind the stereo. Can't miss them it's a big GREEN screw with a ring terminal on a wire under it. Make sure they are tight. Also possible you didn't get something plugged in all the way on the AC.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
k_lundquist
V36 General Tech Questions
4
08-29-2008 09:39 PM
Riker
G35 Coupe V35 2003 - 07
6
04-19-2006 11:26 AM
damen
Forced Induction
5
02-01-2005 01:37 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Gauges reading incorrectly


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: