Car running poor! Help!! - G35Driver - Infiniti G35 & G37 Forum Discussion

TSB- Technical Bulletins Technical Service Bulletins- Coupe and Sedan from Infiniti. Updates Approved by Administrators and Moderators.

Car running poor! Help!!

  #1  
Old 10-26-2015, 04:30 PM
Registered User
Thread Starter
Join Date: Oct 2015
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Car running poor! Help!!

I've had my 03 coupe 6mt for about 3 years now, and the only problem I ever had were some bad 0 2 sensors, I would change the air filters, oil and filter etc, even the spark plugs.
About a year ago my car started to run real poor, it idled high, it would stall, and consume so much gas.
I've tried everything, I've changed the spark plugs, I'd clean the maf sensor, throttle position sensor and it would not fix the issue, but it would get alil better when I clean the intake system. I believe this issue started after I changed the o 2 sensors a year ago, could it be?? In cold starts, it would surge almost like there is too much gas in the motor on start up, so the car would choke up alittle and it has a random misfire too... Last codes I got was, idle was too high, and another one that said, running rich I believe, I've tried it all, have you had this problem? I've done the relearn process, all of them and nothing seems to work. Help please!! I also noticed my air suction isn't as loud as it used to be:/
 
  #2  
Old 12-09-2015, 08:02 AM
Registered User
Join Date: Mar 2011
Location: Central NJ
Posts: 1,946
Thanked 106 Times in 95 Posts
Ever think of following the troubleshooting steps in the FSM?

Telcoman
 
  #3  
Old 12-09-2015, 11:04 AM
VenomGT9's Avatar
Registered User
iTrader: (2)
Join Date: Mar 2013
Location: Chicago
Posts: 1,634
Thanked 129 Times in 124 Posts
Bad fuel? kink in the fuel line or maybe a bad injector?
Possible vacuum leak maybe around the plenum after the spark plug change.
 
  #4  
Old 12-09-2015, 11:41 AM
Registered User
iTrader: (9)
Join Date: Feb 2009
Location: 310 Socal
Posts: 1,009
Thanked 42 Times in 38 Posts
Originally Posted by telcoman View Post
Ever think of following the troubleshooting steps in the FSM?

Telcoman
dude you remind me of the state farm commercial when aaron rodgers asks the fan if that is all he says.

but on topic. it sounds like an air leak. make sure all your connections are tight and there are no holes or disconnected hoses.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Thebaws11
Engine, Drivetrain & Forced-Induction
1
09-12-2015 09:53 PM
joeslates
New Members Check In
1
09-12-2015 12:19 AM
Chadwick Arnold
Engine, Drivetrain & Forced-Induction
0
09-09-2015 03:59 PM
Julianpnce
New Members Check In
10
09-08-2015 05:40 AM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Car running poor! Help!!


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: