Engine, Drivetrain & Forced-Induction Have Technical Questions or Done Modifications to the G35? Find out the answer in here! (View All Posts)

P0507 Code but I have a normal idle

  #1  
Old 01-12-2013, 03:58 PM
Ouija's Avatar
Registered User
Thread Starter
iTrader: (5)
Join Date: May 2011
Location: East Brunswick, NJ
Posts: 319
Received 8 Likes on 6 Posts
P0507 Code but I have a normal idle

Hey guys I have a weird problem, I switched out my plenum and throttlebody for polished ones (disconnected the neg terminal on the battery so I wouldn't have any issues, and I didn't touch the butterfly on the throttlebody) but after driving for about 60-70 miles my CEL came on and when I got it scanned, it said P0507. That code means higher idle than normal, so I did the idle relearn and my idle is back down to 650 (from around 750).

But my CEL is still on and for some reason when my car is warmed up and when it's in idle, there's a weird knocking/sputtering noise that I can only hear when I'm sitting inside the car. Do you guys think there's a vacuum leak? The idle is normal around 650 and the car is driving fine so I'm not sure what is throwing the CEL now.

When I cold start the car though, it will go to 1300-1400 RPM, then come down to 1100RPM.

Any ideas on what could be causing this?
 
  #2  
Old 01-13-2013, 12:14 PM
Ouija's Avatar
Registered User
Thread Starter
iTrader: (5)
Join Date: May 2011
Location: East Brunswick, NJ
Posts: 319
Received 8 Likes on 6 Posts
Anyone?
 
  #3  
Old 01-15-2013, 12:28 AM
Registered User
Join Date: Dec 2012
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Yeah, I have a similar problem..I just got a tune up drove my car home and the next morning i had super high idle and my CEL came on as well. I'm also thinking I have a vacuum leak and the CEL code was P0505...I took apart my throttle body and found nothing was wrong with it. Anybody know whats going on?

sorry for thread jacking just didnt feel like starting a new thread
 
  #4  
Old 01-15-2013, 01:46 PM
Ouija's Avatar
Registered User
Thread Starter
iTrader: (5)
Join Date: May 2011
Location: East Brunswick, NJ
Posts: 319
Received 8 Likes on 6 Posts
Originally Posted by Maybucac View Post
Yeah, I have a similar problem..I just got a tune up drove my car home and the next morning i had super high idle and my CEL came on as well. I'm also thinking I have a vacuum leak and the CEL code was P0505...I took apart my throttle body and found nothing was wrong with it. Anybody know whats going on?

sorry for thread jacking just didnt feel like starting a new thread
Nah dude it's all good, it's weird. When I cold start it'll go to 1400 for 5 seconds, then down to 1100 like normal. When I'm warm idling it's back to 650.

Try the Idle Reset/Pedal Reset and then if your CEL is still on, disconnect the negative terminal on the battery for 1 hr. I did that and my CEL is gone (haven't driven much but I hope it doesn't come back).

The idle reset fixed my warm idle (back to 650) but my cold idle is still weird. I know my throttlebody's fine because my car drives fine. Maybe I should try an ECU Reset as well?
 
  #5  
Old 01-17-2013, 12:25 AM
Former G35driver Vendor
iTrader: (37)
Join Date: Mar 2012
Location: Las Vegas
Posts: 1,081
Received 70 Likes on 59 Posts
#1) reset the ECU
#2) perform the idle relearn test again - it might not be holding the proper rpm


during idle relearn procedure let it idle at the 650 mark for 30 sec before revving or driving
 
  #6  
Old 01-18-2013, 07:08 AM
Registered User
iTrader: (1)
Join Date: Jan 2005
Posts: 252
Received 14 Likes on 11 Posts
I had the same problem when I did some mods with my intake. I kept throwing that P0507 code as well. Turns out I was running lean and needed to get a tune to fix the problem. I ended up going with Uprev and getting it tuned with Osiris on a dyno. That fixed my issue. Some people will say that you don't need a tune. All I can tell you is that I did need a tune to fix the issue. My air fuel mix ratio was off and could have caused problems if I didn't get the tune. I was running lean and that wasn't good.

Not everyone throws a code when the do intake mods. I did and needed it fixed. If you do the ECU reset and throttle reset multiple times, but it still doesn fix the problem, I'd suggest a tune.
 
  #7  
Old 01-18-2013, 10:39 AM
Ouija's Avatar
Registered User
Thread Starter
iTrader: (5)
Join Date: May 2011
Location: East Brunswick, NJ
Posts: 319
Received 8 Likes on 6 Posts
Originally Posted by djhiro View Post
I had the same problem when I did some mods with my intake. I kept throwing that P0507 code as well. Turns out I was running lean and needed to get a tune to fix the problem. I ended up going with Uprev and getting it tuned with Osiris on a dyno. That fixed my issue. Some people will say that you don't need a tune. All I can tell you is that I did need a tune to fix the issue. My air fuel mix ratio was off and could have caused problems if I didn't get the tune. I was running lean and that wasn't good.

Not everyone throws a code when the do intake mods. I did and needed it fixed. If you do the ECU reset and throttle reset multiple times, but it still doesn fix the problem, I'd suggest a tune.
Well my CEL went away and hasn't come back, but my car seems fine now, idling at 650 again after the ECU reset and the throttle reset. I was thinking of getting a tune anyways because JDS motoring in Central Jersey has a special going on for $500 for an uprev tune.

His tunes are usually $600, how much did you pay for yours? I want to see if its reasonable or not.
 
  #8  
Old 01-19-2013, 02:35 AM
Registered User
iTrader: (1)
Join Date: Jan 2005
Posts: 252
Received 14 Likes on 11 Posts
I work overseas and shipped my G back in 04 to Germany. Now, I'm in the UK. I just got my car tuned for the first time this past summer. They charged me 400 british pounds. That's way more than $500-600. I'm not the best example. Hopefully others can comment on their prices better than I.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cmesidewayz
Care & Detailing
1
09-29-2015 09:28 PM
Jnm07
G35 Coupe V35 2003 - 07
10
09-05-2015 01:16 AM
G35CO
G35 Sedan V35 2003-06
0
09-04-2015 09:27 AM
Detailed Image
Care & Detailing
0
09-04-2015 08:35 AM
pdexta
Tuner & Dyno
0
09-02-2015 01:03 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: P0507 Code but I have a normal idle


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: