G35 Coupe V35 2003 - 07 Discussion about the 1st Generation V35 G35 Coupe

Less acceleration as i press the gas pedal harder

  #1  
Old 06-11-2019, 07:05 PM
Registered User
Thread Starter
Join Date: Dec 2018
Location: Tucson, Arizona
Posts: 54
Likes: 0
Received 5 Likes on 3 Posts
G35 Coupe Everything Stock
Less acceleration as i press the gas pedal harder

So there is some pull when i dont press the gas very hard but it seems like the harder i press the gas the less pull there is. It just doesnt feel right. It acts like its gonna get going but doesnt accelerate for crap. Im wondering if it could be a compression issue or if i maybe should change the maf sensor or something. Has a decent pull like i said when i dont press the gas that hard but when i do it sucks. Its like its no longer getting the right air to fuel so it doesnt pull anymore or could it be timing. Im sure someone has come accross this before. Please help, sick of wanting to quickly pass someone and the car get loud but goes no where. I had the clutch replaced recently so that is not the problem. Would it be the transmission even though it pulls at the beginning of the rpms then as the rpms get higher it stops pulling. It also goes in and out of power, sometimes it will accelerate decent, stop accelerating through a little of the rpm then get more power a little later. Sucks it could be so many things.
 
  #2  
Old 06-11-2019, 07:33 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 6,970
Received 815 Likes on 749 Posts
Coupe 6MT Premium RAS
5AT or 6MT ? Sounds like a vacuum leak.
 
  #3  
Old 06-11-2019, 08:24 PM
Premier Member
Join Date: Nov 2018
Posts: 195
Received 19 Likes on 19 Posts
04 G35 Sedan performance package. 70k Eibach springs and sway bars. 19 inch wheels. Plenum spacer.
Originally Posted by [email protected] View Post
5AT or 6MT ? Sounds like a vacuum leak.
I agree.
 
  #4  
Old 06-11-2019, 08:52 PM
Registered User
Thread Starter
Join Date: Dec 2018
Location: Tucson, Arizona
Posts: 54
Likes: 0
Received 5 Likes on 3 Posts
G35 Coupe Everything Stock
its a 6mt
 
  #5  
Old 06-11-2019, 08:57 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 6,970
Received 815 Likes on 749 Posts
Coupe 6MT Premium RAS
If it's a 6MT pay attention to the rpm's in relation to your speed. If the rpm's surge when you stomp on the throttle but the car doesn't move any faster then it's a slipping clutch. However with the loss of power and hesitation/bucking you are having I would start by REMOVING and inspecting all the vacuum lines. Pay particular attention to the PCV system, there is a line right before the throttle body down to the left side valve cover VC, then a hose connecting the two VC on the front of the engine, then the right side VC back up to the center of the intake plenum.

Also remove (unscrew) the PCV valve and shake it to make sure it rattles.

Remove the entire intake plenum and inspect for cracks, you will NOT see them with it installed. If you do find cracks you can temporarily band-aid it along by wrapping it in 3M Super 33+ electrical tape (not cheap jap wrap, super 33+ is really stretchy and will last a long time) which will give you plenty of time to source a replacement.
 
  #6  
Old 06-12-2019, 12:07 AM
Registered User
Thread Starter
Join Date: Dec 2018
Location: Tucson, Arizona
Posts: 54
Likes: 0
Received 5 Likes on 3 Posts
G35 Coupe Everything Stock
The rpms do go up and it doesnt accelerate but i just replaced the clutch so it cant be slipping. Could it be the transmission. I will check all the hoses tomorrow.
 
  #7  
Old 06-12-2019, 12:15 AM
Premier Member
Join Date: Nov 2018
Posts: 195
Received 19 Likes on 19 Posts
04 G35 Sedan performance package. 70k Eibach springs and sway bars. 19 inch wheels. Plenum spacer.
Originally Posted by anusin View Post
The rpms do go up and it doesnt accelerate but i just replaced the clutch so it cant be slipping. Could it be the transmission. I will check all the hoses tomorrow.
If it was running fine before the clutch job, except for your clutch issues, a vacuum line was probably knocked loose or not reconnected properly during the clutch replacement. I'm always suspicious of problems that appear after a recent repair.
 
  #8  
Old 06-12-2019, 08:24 PM
Registered User
Join Date: Feb 2005
Location: Severn, Maryland
Posts: 332
Received 7 Likes on 7 Posts
If the RPM's go up and you are not accelerating, the clutch is definitely slipping. Did you verify the clutch you installed the correct part number? Is the pressure plate bolts torqued to spec and did you use lock-tite to make sure they do not become loose? Was the flywheel in good shape and not glazed? I would go back to whoever did your clutch installation and have them check it out. It is not your transmission, if the gears get messed up, it wouldn't move, or if the synchronizing gears were bad, it wouldn't go into gear with the engine running.
 
  #9  
Old 06-12-2019, 08:40 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 6,970
Received 815 Likes on 749 Posts
Coupe 6MT Premium RAS
I'd like to see a video clip of your dashboard when you step on the gas in 6th gear, it DOES sound like your clutch is slipping from what you've described.
 
  #10  
Old 06-15-2019, 02:57 AM
Registered User
Thread Starter
Join Date: Dec 2018
Location: Tucson, Arizona
Posts: 54
Likes: 0
Received 5 Likes on 3 Posts
G35 Coupe Everything Stock
But it pulls if i just press in the gas a little so if it was the clutch wouldnt it be slipping the whole time. Did an ecu reset and drove it for a while and it pulls at first but then when up to the high rpms or if i step on it then it stops pulling. Could it be the cats are clogged and there is too much back pressure. With the gas pedal pushed a little then its ok because its not as much going through the cats then when i punch it or when it gets higher rpms. I checked the spark plugs and they are white, well i checked one and it was white so its running lean. Is it possible not getting enough gas when i punch it or at higher rpms. I will make a video to show you what it sounds like, hopefully it will help.
 
  #11  
Old 06-15-2019, 02:59 AM
Registered User
Thread Starter
Join Date: Dec 2018
Location: Tucson, Arizona
Posts: 54
Likes: 0
Received 5 Likes on 3 Posts
G35 Coupe Everything Stock
I take that back about stepping on it, it pulls at first when i step on it but then stops pulling as the rpms increase.
 
  #12  
Old 06-15-2019, 09:32 AM
Premier Member
Join Date: Nov 2018
Posts: 195
Received 19 Likes on 19 Posts
04 G35 Sedan performance package. 70k Eibach springs and sway bars. 19 inch wheels. Plenum spacer.
Originally Posted by anusin View Post
I take that back about stepping on it, it pulls at first when i step on it but then stops pulling as the rpms increase.
Your new clutch is bad. Take it back to whoever put it in.
 
  #13  
Old 06-15-2019, 09:49 AM
Registered User
Thread Starter
Join Date: Dec 2018
Location: Tucson, Arizona
Posts: 54
Likes: 0
Received 5 Likes on 3 Posts
G35 Coupe Everything Stock
shoot, the clutch was put in like 7 months ago so i guess its not new anymore, im used to saying i have a new clutch. Its been doing this the whole time though just never thought it would be the clutch because it was just replaced. just my luck though, Think they are still responsible for it even after 7 months. I wasnt sure why it was accelerating at high rpms the whole time, thought it was something else.
 
  #14  
Old 06-15-2019, 12:07 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 6,970
Received 815 Likes on 749 Posts
Coupe 6MT Premium RAS
Make a video of the instrument cluster when you stomp the throttle wide open in 6th gear, then we can see what's happening and if the clutch is slipping we can tell you definitely yes or definitely no.

If it's not slipping but just has no high rpm pull it could be an issue with the timing advance not actuating. I know these engines feel utterly weak if the cam actuators are not working and advancing cam timing.
 
  #15  
Old 06-18-2019, 01:09 AM
Registered User
Thread Starter
Join Date: Dec 2018
Location: Tucson, Arizona
Posts: 54
Likes: 0
Received 5 Likes on 3 Posts
G35 Coupe Everything Stock
Sorry havent made a video yet, but the best way to explain it after just driving for a while was that it has a sweet spot. If i press the gas with a certain force then it will pull and accelerate all throughout the rpms. But if i press it any harder then that its like the air fuel ratio is messed up and is slow. Its always kinda the same amount of force but not always. So im almost positive its not the clutch. I wont be so busy tomorrow so i will make a video and hopefully you can tell. Thanks for all the help.
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Less acceleration as i press the gas pedal harder


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: