Another Coolant System Mystery - G35Driver - Infiniti G35 & G37 Forum Discussion

G35 Coupe V35 2003 - 07 Discussion about the 1st Generation V35 G35 Coupe

Another Coolant System Mystery

Reply

 
 
 
  #1  
Old 07-08-2018, 08:52 PM
Registered User
Thread Starter
Join Date: Nov 2017
Posts: 7
Thanked 0 Times in 0 Posts
Another Coolant System Mystery

2006 G35 Coupe
170K Miles
Stock, Daily Driver (Spacers and Fatter Tires)

Sorry in advance for the lengthy read.

About two months ago my alternator went out and I removed the radiator hose to have better access during the replacing, I wasn't aware of the air in the system issues our car can develop. Fast forward another 2 weeks, I would hear a lot of gurgling in the car on start up and giving it gas but didn't really think much of it. A few weeks of this and I was driving to work on the highway and I noticed that my engine temp was about 80% of the way to H. I immediately threw the heater on full blast in hopes to help lower the heat and all it did was blow cold air at me. Out of nowhere the temp jumped back down and I didn't have an issue for another few weeks. The car overheated on me again as I was going to lunch, go it towed home, same issue and no heater working. Decided I would replace the thermostat (autozone..i know..), after I did this I was still having running hot issues so I did a little more research and learned to burp the system with the bleeder and a spill free funnel. Car ran great for another few weeks until it started to overheat again, same issue with the heater but this time it would blow hot air when i revved the car above 2500 rpms. I replaced the cap and burped the system again. One day later, I was driving to work (Last Friday) and I could smell coolant, looked over at the temp gauge and it was sitting on H, i threw the heater on and nothing so I pulled over and had it towed back home. When I got home I ran a pressure test on the coolant system and it didn't build any pressure at all, after further inspection the radiator had blown out. I replaced the radiator and burped the system, the car stays where its supposed to temp wise with idling and brief drives around the neighborhood. My concerns at this point is I'm not sure I'm getting any flow of coolant through the system, the upper hose is getting decently firm and very hot while the lower is getting semi firm and stays cool. Radiator fans are working as the should and go through the different stages of screaming as the car heats up, I'm trying to pinpoint what the issue is before I continue to throw money at guesses.

Thoughts:
Im not sure if the thermostat isn't opening, the water pump isn't flowing or the head gasket is leaking, at this point in time. I would like some help or any insight from people who know this car better than I. Im going to run a block test and pull the thermostat to check it as well if needed.

Thank you for all your help in advance!
 
Reply With Quote
  #2  
Old 07-09-2018, 09:43 AM
Registered User
Thread Starter
Join Date: Nov 2017
Posts: 7
Thanked 0 Times in 0 Posts
*Update*
System passed the block test.
Removed thermostat and placed in boiling water, didn't open till about 230. Opened about 170 after that each time tested after. Placed in car and could notice the coolant level in the funnel drop when the fans came on. Going to keep my eyes on it and continue to bleed the system over the next few days.
 
Reply With Quote
  #3  
Old 07-10-2018, 04:17 PM
Registered User
Thread Starter
Join Date: Nov 2017
Posts: 7
Thanked 0 Times in 0 Posts
Drove the car to work today. When i arrived both the radiator hoses were pressurized and pretty warm to the touch, would this be a normal thing with our cars? I swore they were both squishy after a drive. No overheating.
 
Reply With Quote
  #4  
Old 07-10-2018, 11:28 PM
cleric670@gmail's Avatar
BANNED!!!
Join Date: May 2017
Location: Washington State
Posts: 4,817
Thanked 490 Times in 466 Posts
Coupe 6MT Premium RAS
Sounds normal.
 
Reply With Quote
  #5  
Old 07-11-2018, 01:19 PM
Registered User
Thread Starter
Join Date: Nov 2017
Posts: 7
Thanked 0 Times in 0 Posts
Originally Posted by [email protected] View Post
Sounds normal.
thank you for reassuring me lol.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Blackbird V35
Cooling
13
06-19-2011 07:35 PM
Andrei
Engine, Drivetrain & Forced-Induction
0
12-18-2010 01:41 AM
EvolutionGSR
Engine, Drivetrain & Forced-Induction
14
08-16-2008 05:52 PM
ratno1
G35 Coupe V35 2003 - 07
3
09-21-2003 02:03 PM
TX_G35
G35 Coupe V35 2003 - 07
4
04-21-2003 12:28 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Another Coolant System Mystery


Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: